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Building a Network and Performing a Steady-State Analysis
Building a Network and Performing a Steady-State 
Analysis

In this lesson, you will draw a schematic model of a simple pipe network connected to 
a larger water distribution system.  You will use a scaled background drawing to assist 
you in drawing the pipe network, and assign user-defined lengths to four pipes.  As 
you draw a schematic of a pipe network, you will enter pipe lengths, while the soft-
ware automatically assigns labels to each pipe and node. If building a scaled model of 
a pipe network, as you draw elements, the software will automatically manage pipe 
lengths based on position of pipes bends, start nodes, and stop nodes, and allow 
customized labeling formats.

To simulate the connection to the larger water distribution network, you will draw a 
reservoir connected to a pump, and enter a pump curve.  The pump curve will be 
developed from 3 data points: the static pressure of the distribution system at the 
connection point (converted to head), partial hydrant flow and pressure (converted to 
head), and full hydrant flow and pressure (converted to head).  This method simulates 
the larger water distribution system's ability to deliver a range of flows and related 
pressures to the new pipe network with a single pump curve.  Representing the 
network connection in this way is an approximation of actual conditions and may not 
be representative for all operational conditions.  Care should be taken to ensure all 
applicable operating conditions are addressed.
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Step 1: Create a New Hydraulic Model File

1. Start WaterGEMS from Start > All Programs > Bentley.

2. On the Welcome dialog click Create New Hydraulic Model; otherwise select 
File > New.

3. If you receive a prompt about associating this file with a CONNECTED 
Hydraulic Model, select Never Prompt. Then click OK

4. Choose Tools > More > Options, Click the Units tab. Since you will be working 
in System International (SI) units, click the Reset Defaults button and select SI.
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5. The first six WaterGEMS Quick Start Lessons use SI units. If you would like to 
set the default unit systems for new Hydraulic Models to be SI, select SI from the 
drop down menu also.

6. Click the Drawing tab to make sure Drawing Mode is set to Scaled. 
Set the Plot Scale Factor 1 cm = 40m

7. Click OK.

8. Set up the Hydraulic Model. Choose File > Hydraulic Model Properties and 
name the Hydraulic Model Lesson 1—Steady State Analysis and click OK.

9. Choose File > Save As. 
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10. Enter the file name MyLesson1 for your model, and click Save.

Step 2: Lay out the Network

1. You will be using a background file to lay out the pipe network.

2. Select View > Backgrounds to open the Background Layers manager. The Back-
ground Layers Manager may already be docked in the lower left corner of your 
screen, its default position. 

3. Right click on the Background Layers folder and select New > File.

4. On the Select Background dialog, browse to Lesson1.dxf in the Lessons folder 
and click Open.

5. Click OK on the DXF Properties dialog to accept the defaults.

6. Click the Zoom Extents button on the top of the drawing area to zoom to the back-
ground, or select View > Zoom Extents.

7. Your drawing should now look like this:
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8. Select the Layout tool from the Home tab.  Follow the instructions below to draw 
the network (see figure on page 2).  Lay out the pipe network in the order shown.  
Any variations can be corrected by right clicking on that element and modifying 
the Label in the Properties Manager.

9. Move the cursor to the drawing pane, right click, and select Reservoir from the 
menu 

10. Click to place R-1 to the left of the existing water main connection. 

11. Move the cursor to the location of pump P-1. Right-click and select Pump from 
the shortcut menu. Click to place it.

12. Right click to select Junction from the menu and click to place J-1.

13. Click to place junctions J-2, J-3, and J-4.P-3, P-4, P-5 will automatically be drawn

14. Click on J-1 to draw P-6.

15. Right-click and choose Done from the menu.

16. Select the Layout tool again from the Home tab.

17. Click on J-3. Move the cursor to the location of J-5, and click. This will insert J-5 
& P-7.
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18. Right-click and select Done.

19. Select the Layout tool again from the Home tab.

20. Click on J-4. Move the cursor to the left towards the location of the PRV. Right 
click to select PRV from the list of elements. 

21. Click to insert PRV-1 in the appropriate location. This will insert PRV-1 & P-8. 
Right click to select Junction from the list of elements.

22. Click to place junction J-6 in the appropriate location. This will insert J-6 & P-9. 
Right click and select Done.

Be sure to lay out the pipes in numerical order (P-7 through P-9), so that their 
labels correspond to the labels in the diagram. 

23. Select the Layout tool again from the Home tab.

24. Click on J-3. Move the cursor upwards towards the location of the Tank. Right 
click to select Tank from the list of elements. 

25. Click to insert the tank, T-1. Pipe P-10 should connect the tank to the network if 
you laid out the elements in the correct order.
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26. Your model should now look like this:

27. Save the model by clicking Save or choose File > Save.

Step 3: Enter and modify data

• Property Editor—You can use the Select tool and double-click an element to 
bring up its Property Editor. In AutoCAD, click the element once with the Select 
tool to open the element’s editor.

• FlexTables—You can click on FlexTables  to bring up dynamic tables that allow 
you to edit and display the model data in a tabular format. You can edit the data as 
you would in a spreadsheet.

• User Data Extensions—The User Data Extensions feature allows you to import 
and export element data directly from XML files.

• Alternative Editors—Alternatives are used to enter data for different “What If?” 
situations used in Scenario Management. 

Entering Data through Property Editor
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To access an element’s property editor in WaterGEMS, double-click the element.

1. Open the Reservoir Editor for reservoir R-1 by double-clicking on R-1.

2. Enter the Elevation as 198.

3. Set Zone to Connection Zone.

a. Click the menu to Edit Zones which will open the Zones Manager.

b. Click New.

c. Enter a label for the new pressure zone called Connection Zone.

d. Click Close.

e. Select the zone you just created from the Zone menu. 

f. Close the Reservoir Property Editor.

4. Double click on tank T-1 and enter the following:
Elevation (Base) = 200
Elevation (Minimum) = 220
Elevation (Initial) = 225
Elevation (Maximum) = 226
Diameter (m) = 8
Section = Circular
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Set the Zone to Zone 1(You will need to create Zone-1 in the Zone Manager as 
described above.) 

5. Close the Tank Property editor.
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6. Double click on pump PMP-1.

a. Enter 193 m for the Elevation.

b. Click in the Pump Definition field and click on Edit Pump Definitions from 
the drop-down list to open the Pump Definitions manager.

c. Click New to create a new pump definition. Name it PMP-1. 

d. Select Standard (3 Point) from the Pump Definition Type menu.

e. Right click on Flow to open the Units and Formatting menu. 

f. Click on it and then in the Set Field Options dialog, set the Units to L/min

.

g. Click OK.
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h. Enter the following information:

i. The Pump Definitions Manager should look like 
this:

j. Click Close.

k. In the Property Editor, select PMP-1 from the Pump Definition menu.

l. Close the Pump’s Property Editor

7. Double click valve PRV-1 in the drawing. Enter in the following data: 
Status (Initial) = Active 
Setting Type= Pressure 
Pressure Setting (Initial)= 390 kPa 
Elevation =165 m 
Diameter (Valve) = 150 mm 
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8. Create Zone 2 and set the valve’s Zone field to Zone-2. 

Close the PRV Property Editor.

Enter the following elevation, demand, and zone data for J-1 through J-6 through the 
Junction Property Editor. Leave all other fields set to their default values

Junction Ground 
Elevation 

(m)

Zone Demand 
(l/min)

J-1 184 Zone-1 38
J-2 185 Zone-1 31
J-3 184 Zone-1 34
J-4 183 Zone-1 38
J-5 185.5 Zone-1 350
J-6 165 Zone-2 356
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9. Click the ellipsis  in the Demand Collection field to open the Demands 
manager enter each value for the Demand Base Flow (L/min).  You may need to 
right-click on Demand (Base) column > Units and Formatting… > and set Unit to 
L/min.

10. Close the Junction Property Editor.

11. Specify user-defined lengths for pipes P-1, P-7, P-8, P-9 and P-10.

a. Double-click pipe P-1 to open the Pipe Property Editor.

b. Set Has User Defined Length? to True. Then, enter a value of 0.01 m in the 
Length field. Since you are using the reservoir and pump to simulate the 
connection to the main distribution system, you want headloss through this 
pipe to be negligible. Therefore, the length is very small and the diameter will 
be large.

c. Enter 1000 mm as the diameter of P1.

d. Change the lengths (but not the diameters) of pipes P-7 through P-10 using 
the following user-defined lengths: 
P-7 = Length (User Defined): 400 m 
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P-8 = Length (User Defined): 500 m 
P-9 = Length (User Defined): 31 m 
P-10 = Length (User Defined): 100 m 

e. Close the Pipe Property Editor.

Step 4: Entering Data through FlexTables

It is often more convenient to enter data for similar elements in tabular form, rather 
than to individually open the Property Editor for an element, enter the data, and then 
select the next element. Using FlexTables, you can enter the data as you would enter 
data into a spreadsheet.
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To use FlexTables

1. Click the FlexTables button on the Home tab or choose View > FlexTables.

2. Double-click Pipe Table. Fields that are white can be edited, yellow fields can not. 
The Flextable columns have been re-ordered in the figure below.
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3. Enter the pipe diameters as shown in this table:

4. To enter the pipe material type for P-4 & P-7, click the appropriate pipe material 
cell, then click the ellipsis to open the Engineering Libraries. Expand Material 
Libraries > Material Libraries.xml, click PVC, then click Select
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Notice that the C values for the pipes will be automatically assigned to preset values 
based on the material; however, these values could be modified if a different coeffi-
cient were required. 

5. Leave other pipe data set to default values. Close the Pipe Flex Table and Property 
Editor when finished.

Step 5: Run a Steady-State Analysis

1. Click Analysis > Options to open the Calculation Options manager.

2. Double-click Base Calculation Options under the Steady-State/EPS Solver 
heading to open the Property Editor. Make sure that the Time Analysis Type is set 
to Steady State.

3. Close the Property Editor and the Calculation Options manager..

4. Click Analysis > Validate, then click Ok if no problems are found.
18 Bentley WaterGEMS Quick Start Lessons



WaterGEMS Quick Start Lessons
5. Click Compute  on the Home or Analysis tabs to analyze the model. 

6. When calculations are completed, the Calculation Summary will open. A blue 
light is an informational message, a green light indicates no warnings or issues, a 
yellow light indicates warnings, and a red light indicates issues.

7. Close the Calculation Summary dialog.

8. Save your file
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Extended Period Simulation

This lesson will illustrate how to model a water distribution system over time using 
the extended period simulation (EPS) calculation engine and by adding demand 
patterns to junctions. An EPS can be conducted for any duration you specify. System 
conditions are computed over the given duration at a specified time increment. Some 
of the types of system behaviors that can be analyzed using an EPS model include 
how tank levels fluctuate, when pumps are running, whether valves are open or 
closed, and how demands change throughout the day.

Opening the existing Hydraulic Model

This lesson is based on the Hydraulic Model created in Building a Network and 
Performing a Steady-State Analysis. If you have not completed it, then open the 
Hydraulic Model Lesson2.wtg from the Lessons directory. If you completed Lesson 
1, then you can use the MyLesson1 file you created.

1. Open MyLesson1.wtg. (or Lesson2.wtg)

2. Click OK to the message dialog that comes up about CONNECTED Projects

3. After you have opened the file, choose File > Save As.

4. Enter the filename MyLesson2 and click Save.

5. Choose File > Hydraulic Model Properties, and change the Title to Lesson 2—
Extended Period Simulation. 

6. Click OK.
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Step 1: Creating Demand Patterns

Water demand in a distribution system fluctuates over time. For example, residential 
water use on a typical weekday is higher than average in the morning before people 
leave for work, and is usually highest in the evening when residents are home and 
preparing dinner, washing clothes, etc. This variation in consumption over time can be 
modeled using demand patterns. Demand patterns are multipliers that vary with time 
and are applied to a given base demand, most typically the average daily demand.

In this lesson, you will be dividing the single fixed demands for each junction node in 
Lesson 1 into two individual demands with different demand patterns. One demand 
pattern will be created for residential use, and another for commercial use. You will 
enter demand patterns at the junction nodes through the junction's property editor. 

1. Open the Property Editor for Junction J-1 (double-click junction J-1) and click the 
ellipsis in the Demand Collection field to open the Demands box.

2. By default, the demand pattern is set to Fixed. Enter 23 l/min for Flow. (If field 
already has a number from previous lesson, type over it.)
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3. Click in the Pattern (Demand) field and click the ellipsis to open the Patterns 
manager.

4. Highlight the Hydraulic folder and click New to create a hydraulic pattern. 

a. Rename the new pattern Residential.

b. Leave the Start Time 12:00:00 AM.

c. Enter 0.5 as the Starting Multiplier.

d. In the Pattern Format menu select Stepwise.

The resulting demand pattern will have multipliers that remain constant until 
the next pattern time increment is reached.

Note that the multiplier for the last time given (24 hrs.) must be the same as 
the Starting Multiplier (0.5). These values are equal because the demand 
curve represents a complete cycle, with the last point the same as the first.

e. Under the Hourly tab, enter the following times and multipliers:

Time from 
Start

Multiplier

3 .4

6 1

9 1.3

12 1.2
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f. The Residential Pattern should look like the following:

5. Highlight the Hydraulic folder again and click New to create a new pattern for 
commercial demands.

a. Rename the new pattern Commercial.

b. Leave the Start Time 12:00:00 AM.

c. Enter 0.4 as the Starting Multiplier.

15 1.2

18 1.6

21 .8

24 .5
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d. In the Pattern Format menu select Stepwise.

e. Under the Hourly tab, enter the following times and multipliers:

Time from 
Start

Multiplier

3 .6

6 .8

9 1.6

12 1.6

15 1.2

18 .8

21 .6

24 .4
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f. The Commercial Pattern should look like the following:

6. Click Close.

7. Back in the Pattern field, for J-1 select Residential from the menu.

8. In the second row, enter a flow of 15 l/min and select Commercial as the pattern 
for this row.

9. Close the Demands dialog box.
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10. Close the J-1 Property Editor.

11. Enter the following demand data for the remainder junctions using the Residen-
tial and Commercial demand patterns already created. 

12. You can easily enter this data by using the Demand Control Center in Compo-
nents > Demand Center > Demand Control Center.

13. If you receive a message about cancel and undo not being available for the 
Demand Control Center, click Yes to continue.

14. Enter the demand and corresponding pattern for each of the junctions. To enter a 
second demand for a junction, select the desired junction’s label in the table and 
click the down arrow next to New and select Add Demand to Element (J-#) as 
needed.
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15. When you are done, the Demand Control Center will look like this:

16. Now you will set up an additional demand pattern to simulate a three-hour fire at 
node J-6.

a. Highlight the label J-6 and click New > Add Demand to Element (J-6) 

b. Enter a Demand (Base) of 2000 l/min.

c. Click the Pattern column and select the ellipsis button to open the Patterns 
Manager.

d. Highlight the Hydraulic folder, then click New to create a new pattern.

e. Rename the new pattern 3-Hour Fire

f. Leave the Start Time 12:00:00 AM

g. Enter 0.00 as the Starting Multiplier. 

h. Select the Stepwise format.
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i. Under the Hourly tab, enter the following times and multipliers:

j. After you have filled in the table, look at the Graph in the lower section of the 
Patterns manager.

The value of the multiplier is zero, except for the period between 18 and 21 
hours, when it is 1.0. Since the input the demand as 2000 l/min., the result will 
be a 2000 l/min. fire flow at junction J-6 between hours 18 and 21.

Time from 
Start

Multiplier

18 1

21 0

24 0
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k. Click Close.

17. Select the new pattern, 3-Hour Fire, from the Pattern (Demand) selection box.

18. Close the Demand Control Center.
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Step 2: Running an Extended Period Simulation (EPS)

1. Go to Analysis > Options to open the Calculation Options dialog.

2. Double-click Base Calculation Options under Steady State/EPS Solver to open 
the property editor and select EPS from the Time Analysis Type menu

3. Click Analysis > Validate, then click Ok if no problems are found.

4. Click Compute on the Home or Analysis tabs to analyze the model. 

5. The Calculation Summary opens.
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6. Close the Calculation Summary.

7. When there are errors or warnings then the User Notifications dialog box opens. A 
blue light is an informational message, a yellow light indicates warnings, and a 
red light indicates issues. 

8. Close the User Notifications dialog box and other open dialogs.

9. Click Save or choose File > Save to save the Hydraulic Model.
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Scenario Management

One of the many Hydraulic Model tools in Bentley WaterGEMS is Scenario Manage-
ment. Scenarios allow you to calculate multiple “What If?” situations in a single file. 
You may wish to try several designs and compare the results, or analyze an existing 
system using several different demand alternatives and compare the resulting system 
pressures.

A scenario is a set of Alternatives, while alternatives are groups of actual model data. 
Scenarios and alternatives are based on a parent/child relationship where a child 
scenario or alternative inherits data from the parent scenario or alternative.

In Lessons 1 and 2, you constructed the water distribution network, defined the char-
acteristics of the various elements, entered demands and demand patterns, and 
performed steady-state and extended period simulations. In this lesson, you will set up 
the scenarios needed to test four “What If?” situations for our water distribution 
system. These “What If?” situations will involve changing demands and pipe sizes. At 
the end of the lesson, you will compare all of the results using the Scenario Compar-
ison tool.

Opening the existing Hydraulic Model

This lesson is based on the Hydraulic Model created in Extended Period Simula-
tions. If you have not completed it, then open the Hydraulic Model Lesson3.wtg from 
the Lessons folder. If you completed Lesson 2, then you can use the MyLesson2 file 
you created.

1. Open MyLesson2.wtg (or Lesson3.wtg)

2. Click OK to the message dialog that comes up about CONNECTED Projects.

3. After you have opened the file, choose File > Save As.

4. Enter the filename MyLesson3 and click Save.

5. Choose File > Hydraulic Model Properties, and change the Title to Lesson 3—
Scenario Management. 
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6. Click OK.

Step 1: Create a New Alternative

First, you need to set up the required data sets, or alternatives. An alternative is a 
group of data that describes a specific part of the model. 

There are fifteen alternative types:

In this example, you need to set up different physical and demand alternatives for each 
design trial you want to evaluate. Each alternative will contain different pipe sizes or 
demand data.

In Bentley WaterGEMS, you create families of alternatives from base alternatives. 
Base alternatives are alternatives that do not inherit data from any other alternative. 
Child alternatives can be created from the base alternative. A Child alternative inherits 
the characteristics of its parent, but specific data can be overridden to be local to the 
child. A child alternative can, in turn, be the parent of another alternative.

1. Choose Analysis > Alternatives. 

2. Expand the Demand alternative. The Base Demand alternative contains the 
demands for the current distribution system.
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3. Change the default demand name.

a. Select Base Demand, then right click to rename it.

b. Enter the new name, Average Daily with 2000 l/min. Fire Flow.

c. Double-click on the alternative to open the Demand Alternative manager.

4. Close the Demand Alternative Manager.
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5. Now you should add a child of the Average Daily with 2000 l/min. Fire Flow 
alternative, because the new alternative will inherit most data. Then, you can 
locally change the data that you want to modify. You will modify the existing 
demand data by increasing the fire flow component at node J-6 from 2000 l/min. 
to 4000 l/min.

a. In the Alternatives manager, right-click the Average Daily with 2000 l/min. 
Fire Flow alternative, then select New > Child Alternative. 

b. Highlight the new alternative and click Rename. Enter a label of 4000 l/min 
Fire Flow for the new Alternative. 

c. Double-click to open the Demand Alternatives editor for the new alternative 
which shows the data that was inherited from the parent alternative (Empty 
check box next to ID)

If you change any data, the check box will become selected because that record is now 
local to this alternative and not inherited from the parent.
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6. Click in the Demand Collection column for node J-6. Change the 2000 l/min. fire 
demand to 4000 l/min.

7. Close to exit the Demand Alternative Editor.

8. Close the Alternatives Manager
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Step 2: To create and edit Scenarios

Alternatives are the building blocks of a scenario. A scenario is a set of one of each of 
the types of alternatives, plus all of the calculation information needed to solve a 
model.

Just as there are base, parent, and child alternatives, there are also base, parent, and 
child scenarios. The difference is that instead of inheriting model data, scenarios 
inherit sets of alternatives. To change the new scenario, change one or more of the new 
scenario’s alternatives. For this lesson, you will create a new scenario for each 
different set of conditions you need to evaluate. 

1. Choose Analysis > Scenarios to open the Scenario Manager.

There is always a default Base Scenario that is composed of the base alternatives. 
Initially, only the Base is available, because you have not created any new 
scenarios. 

2. Rename the Base Scenario to 2000 l/min., 3-hour Fire Flow at J-6 (EPS).
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3. Create a child scenario from the existing base scenario to incorporate the new 
demand alternative.

a. Right-click on the 2000 l/min., 3-hour Fire Flow at J-6 (EPS) scenario and 
select New > Child Scenario.

b. Enter a scenario name of 4000 l/min. Fire Flow at J-6 (EPS). Double-click 
the scenario to open the Property Editor for the scenario. 

The new scenario lists the alternatives as inherited from the base scenario.
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4. Your new Child Scenario initially consists of the same alternatives as its parent 
scenario. Set the Demand Alternative to the new alternative you created, 4000 l/
min. Fire Flow.

a. Click in the Demand Alternative field

b. From the menu, select the 4000 l/min. Fire Flow alternative. 

Now the demand alternative of the new child Scenario is no longer inherited 
from the parent scenario, but is local to this scenario.

c. Close the Property Editor.
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Step 3: To calculate both of the scenarios using the Batch Run tool

1. In the Scenario Manager, click the down arrow next to Compute and Select 
Batch Run

.

2. Select both check boxes next to the scenario names in the Batch Run dialog.

3. Click Batch.

4. Click Yes at the prompt to run the batch for two scenarios.

5. After computing finishes, click OK.

Step 4: To create a Physical Alternative

You need to further examine what is going on in the system as a result of the fire flow, 
and find solutions to any problems that might have arisen in the network as a result. 
You can review output tables to quickly see what the pressures and velocities are 
within the system, and create new alternatives and scenarios to capture your modifica-
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tions. Notice that in the 4000 l/min. Fire Flow at J-6 scenario, pressure at J-6 drops 
below vapor pressure for the entire duration of the fire flow (18-21hrs) indicating that 
such high flow could not be supplied. We will try to increase pipe sizes for P-8 and P-
9 to 200 mm.

1. A new physical alternative will be created to contain the new pipe sizes. Click 
Analysis > Alternatives. Under Physical, highlight Base Physical. Right click 
and select New > Child Alternative. 

1. Rename the new Child Alternative P-8 and P-9 Set to 200 mm. 

1. Double-click the newly created physical alternative to open the Physical alterna-
tive editor. 

2. In the Pipe tab for this Alternative, change the diameter for pipes P-8 and P-9 to 
200 mm. 

3. Close the alternative editor dialog.
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4. Create a new scenario having the new physical alternative with the pipe sizes for 
P8 and P-9 increased to 200 mm. 

5. Choose Analysis > Scenarios.

d. Select 4000 l/min. Fire Flow at J-6 (EPS) in the list of Scenarios.

e. Right click to select New > Child Scenario.

f. Name the new Scenario P-8 and P-9 Set to 200 mm.

g. Double click scenario P-8 and P-9 Set to 200 mm to open the Property Editor 
for the scenario. Click Physical and select the P-8 and P-9 Set to 200 mm 
alternative.

h. Close the Property Editor to return to the Scenarios Manager.

i. Highlight the P-8 and P-9 Set to 200 mm scenario and right click to Make 
Current. A red check mark on the scenario’s icon indicate that this is the 
current scenario.

j. Click Compute to run the Scenario.

6. Close the open boxes and save the model.
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Reporting Results

An important feature in all water distribution modeling software is the ability to 
present results clearly. This lesson outlines several of Bentley WaterGEMS reporting 
features, including:

• Element Tables (FlexTables), for viewing, editing, and presentation of selected 
data and elements in a tabular format.

• Profiles, to graphically show, in a profile view, how a selected attribute, such as 
hydraulic grade, varies along an interconnected series of pipes.

• Contouring, to show how a selected attribute, such as pressure, varies throughout 
the distribution system.

• Element Annotation, for dynamic presentation of the values of user-selected 
variables in the plan view.

• Color Coding, which assigns colors based on ranges of values to elements in the 
plan view. Color coding is useful in performing quick diagnostics on the network.

• Reports, which display and print information on any or all elements in the 
system.

For this lesson, you will use the file from the Scenario Management lesson, saved as 
MyLesson3.wtg in the Lessons folder. If you did not complete this lesson, you may 
use the file Lesson4.wtg.

To open the existing Hydraulic Model

1. Open MyLesson3.wtg (or Lesson4.wtg).

2. Click OK to the message dialog that comes up about CONNECTED Projects.

3. Select File > Save As.

4. Enter the filename MyLesson4, and click Save.

5. Select File > Hydraulic Model Properties, and change the Title to Lesson 4 - 
Reporting Results.
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FlexTables

When data must be entered for a large number of elements, clicking each element and 
entering the data can be time consuming. FlexTable fields can be changed using the 
global edit tool, or filtered to display only the desired elements. Values that are entered 
into the table will be automatically updated in the model. The tables can also be 
customized to contain only the desired data. Columns can be added or removed, and 
the order in which they appear can be rearranged.

FlexTables are dynamic tables of input values and calculated results. White columns 
are editable input values, and yellow columns are non-editable calculated values. 
When data is entered into a table directly, the values in the model will be automati-
cally updated. These tables can be printed or copied into a spreadsheet program.

Global Edit and Filtering are very useful tools. For example, if you decide to evaluate 
how the network might operate in five years. Assume that the C factor for 5-year old 
ductile iron pipe reduces from 130 to 120. It would be repetitive to go through and edit 
the pipe roughness through the individual pipe Property Editors, particularly when 
dealing with a large system. Instead, you will use the filter tool in this example to filter 
out the PVC pipes, and then use global edit tool to change the pipe roughness on the 
ductile iron pipes only.

To use Global Edit and Filtering

1. Set up a new Alternative and Scenario to capture the changes to the C values.

a. Click Analysis > Alternatives. Highlight the P-8 and P-9 Set to 200 mm 
Physical Alternative and click New Child Alternative. 

b. Rename the new Alternative 5-yr.-old D.I.P. 

c. Close the Alternatives manager.

d. Choose Analysis > Scenarios.

e. Select the P-8 and P-9 Set to 200 mm scenario.

f. Right click and select New > Child Scenario.

g. Rename the new scenario 5-yr.-old D.I.P.

h. Double-click the new scenario to open the Property Editor. Change the Phys-
ical alternative to 5-yr.-old D.I.P.

i. Close the scenario manager.
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2. Choose View > FlexTables > Pipe Table.

3. Right-click the Material column and choose Filter > Custom from the menu. 

4. The query builder opens.

a. Double-click on Material.

b. Click the = equal sign.
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c. Click  to select the Unique Values for Material

d. Double-click Ductile Iron.

e. Click Apply , then Click OK.

f. Click OK to exit the query builder.

5. Use the Global Edit tool to modify all of the roughness values in the table.

a. Right-click the Hazen-Williams C column and select Global Edit.

b. Select Set from the Operation list.

c. Enter 120 into the Global Edit field.

d. Click OK. All of the values are now set to 120.

6. To deactivate the filter, right-click on any column header and click Filter > Reset 
from the menu. Click Yes to reset the filter.
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7. You may also wish to edit a table by adding or removing columns.

a. Click Edit  to open the table editor.

b. Scroll through the list on the left to view the types of data available for place-
ment in the table. You can select an item to add or remove from the table.

c. You can adjust the order in which the columns will be displayed by using the 

arrows below Selected Columns .

d. Click Ok to save your changes or Cancel to exit the table without making 
changes.

8. Close the table.
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9. Choose Analysis > Scenarios > Compute Scenario > Batch Run.

10. Check 5-yr.-old D.I.P., and then click Batch.

11. Close the table when you are finished.

Create a Print Preview and Profile

1. To create a print preview of the distribution system, choose File > Print > Print 
Preview. Leave the Settings as “Fit To Page”.

This option will create a preview of the entire system regardless of what the 
screen shows.
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The print preview opens in a separate window, which can then be printed or 
copied to the clipboard.

2. Close the print preview window.

3. To create a profile view, choose View > Profiles. This activates the Profiles 
manager. 

4. Click New to open the Profile Setup manager, and then click Select From 
Drawing to choose the elements to profile.

5. The dialog box closes and Select opens. Choose a few elements (or a path by 

clicking on the first and last elements of the desired path) and click Done .
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6. The Profile Setup opens with the selected elements appearing, in order, in the list.

Click Open Profile to view the profile.
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7. Profile Series Options opens so you can select which attributes to profile. The 
default fields are Elevation and Hydraulic Grade. Leave those defaults and click 
OK to Open the profile.
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8. After you create the profile, you can make adjustments to its appearance by 

clicking on Series Options 

9. The profile graph can be printed or copied to the clipboard.

10. Close the Profile window.

11. Close the Profile manager.

To create a contour

The contouring feature in Bentley WaterGEMS enables you to generate contours for 
reporting attributes such as elevation, pressure, and hydraulic grade. You can specify 
the contour interval, as well as color code the contours by index values or ranges of 
values. In this lesson, you will contour based on hydraulic grade elevations.

1. Choose View > Contours .

2. Click New in the Contour Manager.
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3. Choose Hydraulic Grade from the Field menu. 

4. Leave the default Selection Set.

5. Click Initialize and select Full Range to update the Minimum and Maximum 
HGL elevations.

6. Make sure Color by Index is selected

7. Select Smooth Contours to improve the overall appearance of the drawing.

8. Click OK.
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9. View the results in the drawing pane.

10. Click on the Contour Browser button  to display the calculated Hydraulic 
Grade as you move the cursor around in the drawing pane. 

11. Close the Contour Browser.

12. Un-check Contour Definition -1 in the Contours Manager.

13. Close the Contours Manager
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Element Symbology

When you want to label network attributes use the Annotation feature. With it, you 
can control which values are displayed, how they are labeled, and how units are 
expressed. 

Select View > Symbology to open the Element Symbology manager if you have 
closed it previously. If you are using the default workspace configuration, the Element 
Symbology manager is located directly on the left side of the drawing pane. 

Annotate Pressure at junctions

14. In the Element Symbology Manager, highlight Junction. Right click to select 
New > Annotation
.

15. Select Pressure as the Field Name to annotate. Set the Prefix to P: and the Y 
Offset to 25 m. Leave everything else as is.
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16. Click Apply.

17. The drawing will now display all of the annotations. You can try changing the 
properties of an element and recalculating. The annotations will update automati-
cally to reflect any changes in the system. 

18. If the annotation is crowded, you can click and drag the annotation to move it.

19. Click OK.

Color Coding

Choose View > Symbology and click the element to create the New Color Coding. 
The Color Coding dialog box allows you to set the color coding for links, nodes, or 
both. You will color code by velocity (link attribute) and pressure (node attribute) in 
this example.

1. In the Element Symbology Manager, highlight Pipe. Right click to select New > 
Color Coding

a. Select Velocity from the Field Name menu.

b. Calculate Range > Full Range so the program can calculate the full range of 
velocity values for all pipes in this scenario. The minimum and maximum 
fields should be populated. Leave the default Steps value to be 5.

c. Set Options to Color. 
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d. Click Initialize so the program selects the color coding ranges automatically 
based on the Minimum, Maximum and Steps values. 

e. Click OK to generate the Color Coding.

2. You can add a legend to the drawing. Right-click on the Velocity color coding and 
select Insert Legend from the menu. You can move the legend in the drawing by 
clicking the mouse and dragging the legend.

1. In the Element Symbology Manager, highlight Junction. Right click to select 
New > Color Coding

a. Select Pressure from the Field Name menu.

b. Calculate Range > Full Range. Leave the default Steps value to be 5.

c. Set Options to Color and Size

d. Click Initialize 

e. Click OK to generate the Pressure Color coding.

2. Go to Home > Times and then click the Play button to observe how the pressure 
and velocity change, particularly during hours 18-21.

3. Close any open dialog boxes.

4. Save the model.
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Automated Fire Flow Analysis

One of the primary goals of a water distribution system is to provide adequate 
capacity to fight fires. Bentley WaterGEMS automated fire flow analysis can be used 
to determine if the system can meet the fire flow demands while maintaining 
minimum pressure constraints. Fire flows can be computed for all nodes in the system, 
or you can create a selection set consisting of specific nodes where you wish to test 
available flow.

Fire flows are computed at each node by iteratively assigning demands and computing 
system pressures. The model assigns the fire flow demand to a node and checks the 
model, checking to see if all pressure and velocity constraints are met at that demand. 
If a constraint is not met, the flow is reduced until the constraint is just met; if all 
constraints are exceeded, the fire flow is increased until the constraint is barely met 
within a tolerance. The analysis automatically rechecks the system pressures if a 
constraint is violated. Iterations continue until the constraints are met, or until the 
maximum number of iterations is reached.

The purpose of this example is to walk you through the steps to create, calculate, and 
analyze a fire-flow scenario. This lesson again uses the distribution system from the 
previous lessons.

Step 1: Inputting Fire Flow Data

1. Start WaterGEMS and open the Lesson5.wtg file, found in the Lessons folder.
Or
if you have previously completed the Reporting Results lesson, you can use your 
MyLesson4 file. 

2. Click OK to the message dialog that comes up about CONNECTED Projects.

3. Choose File > Save As and save as MyLesson5.
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4. Choose File > Hydraulic Model Properties and name the title of the Hydraulic 
Model Lesson 5—Fire Flow Analysis.

5. Click OK.

6. Previously, you ran an analysis with a fire flow at node J-6 by manually adding a 
large demand to the individual node. Before running the automated fire flow anal-
ysis, you will create a new Demand Alternative, removing that demand. In the 
U.S., fire flows are generally added to max day demands.

a. Choose Analysis > Alternatives.

b. Expand the Demand Alternative and select Average Daily with 2000 l/min 
Fire Flow. Right-click and select New > Child Alternative. 

c. Right click to Rename this Alternative Base-Average Daily.
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d. Double-click to open the Base-Average Daily alternative and put a check in 
the box for J-6. 

e. In the Demands tab, select the row with 2,000 Flow and 3-Hour Fire and click 

to delete it.

f. Click Close to exit the Demand Alternative.

7. You are going to analyze the fire flows by adding to the Maximum Day Demands, 
which are 1.5 times the Average Day Demands.

a. Right-click on Base-Average Daily then select New > Child Alternative.

b. Right click to Rename this Alternative Max. Day.
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c. Double click to open the Max. Day alternative.Highlight the J-1 row. Right-
click the Demand (Base) column and select Global Edit. Set the Operation to 
multiply, and enter a value of 1.5. 

d. Click OK.

e. Repeat steps c and d for J-2 through J-6. 

f. Click Close to exit the Demand Alternative.

8. Select the Fire Flow alternative and expand to select the Base-Fire Flow Alterna-
tive.

9. Double click to set up the Base-Fire Flow Alternative.

a. In the Fire Flow (Needed) field, enter 3000 l/min. 

b. In the Fire Flow (Upper Limit) field enter 6000 l/min. 

c. Apply Fire Flows By should be set to Adding to Baseline Demand. 

This selection means that when WaterGEMS performs the analysis, the fire flow 
will be added to any demands already assigned to the junction. Alternatively, you 
could have selected to replace these demands, so that the fire flow would repre-
sent the total demand at the node. 

d. Pressure Constraints Pressure (Residual Lower Limit) and Pressure (Zone 
Lower Limit) should be set to 150 kPa. 

e. Leave the check box for Use Minimum System Pressure Constraint 
cleared, so that the minimum pressure will only be checked for the zone a 
particular node is in. 

If you had  multiple zones within your project and wanted to insure that a 
minimum  system-wide  pressure  constraint  was  met,  you  could  check  the Use  
Minimum System Pressure Constraint  box  and  enter  it  in  the  box provided. 
This box is grayed out until the check box is activated. 
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f. Create a selection set to choose from the Fire Flow Nodes drop-down menu. 
For this example, a fire flow analysis is only needed for the junctions at the 
four street corners in our drawing. 

g. The Fire Flow Alternative manager can remain open. In the drawing and 
while pressing the <Shift> key, click nodes J-1, J-2, J-3, and J-4. 

h. Right-click and select Create Selection Set, then name the set FireFlow-
Junction1-4 and click OK. 

i. In the Fire Flow Alternative manager, select FireFlowJunction1-4 from the 
Fire Flow Nodes drop-down menu.

10. Click Close to exit the Fire Flow Alternative manager.
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Step 2: Calculating a Fire Flow Analysis

1. Click Analysis > Scenarios.

2. In the Scenarios dialog, click New > Base Scenario. 

3. Name the new Scenario Automated Fire Flow Analysis. 

4. Double-click the Automated Fire Flow Analysis scenario to open the Property 
Editor. 

a. Change the Physical Alternative to P-8 and P-9 Set to 200 mm. 

b. Change the Demand to Max. Day and leave all other Alternatives set to their 
defaults. 

c. Close the properties dialog

5. In the Scenarios manager, make Automated Fire Flow Analysis the current 

scenario by highlighting it and clicking the Make Current button 

6. Click Analysis > Options.

7. In the Calculation Options dialog, Select Steady State/EPS Solver and click the 
New button. Rename the new option Automated Fire Flow Analysis.

8. Double click Automated Fire Flow Analysis to open the Property Editor.
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9. Change the Calculation Type to Fire Flow. Close the Calculation Options dialog.

10. Choose Analysis > Scenarios.

11. Double click Automated Fire Flow Analysis Scenario to open the Property 
Editor.
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d. Change the Calculation Options to Automated Fire Flow Analysis.

e. Close the Property Editor.

f. Run the Automated Fire Flow Scenario by selecting Compute on the Home 
or Analysis tabs, or by clicking the Compute button in the Scenario manager. 

g. If you receive a prompt about running Fire Flow Calculations in parallel,  
click OK. This option enables the user to choose (or not) hyperthreading in an 
attempt to make the fire flow runs faster..

When the calculation is complete, Close the Calculation Summary.
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Step 3: Viewing Fire Flow Results

1. Make sure that Automated Fire Flow Analysis is selected in the Scenario list 
box.

2. Click Analysis > Fire Flow Results > Fire Flow Report

In the Satisfies Fire Flow Constraints column, all of the boxes are checked except 
for the nodes that you did not analyze, because the specified needed flow of 3000 
l/min. was available and minimum pressures were exceeded.

For nodes J-1 and J-3, pressures were computed for the Fire Flow Upper Limit of 
6000 l/min. because none of the node pressures ever dropped below specified 
minimum pressures and no velocity constraint was specified.

Nodes J-2 and J-4 reached their minimum residual pressures at flows slightly 
below the maximum of 6000 l/min.

The report contains the Minimum System Pressure (excluding the current node 
being flowed) and its location. 

3. Click Analysis > Fire Flow Results > Fire Flow Results

The Fire Flow Results Browser reports whether each of the fire flow nodes satisfies 
constraints or not. It also allows you to jump to fire flow nodes and display the results 
of fire flow analysis at the highlighted node if you have specified Auxiliary Output 
options in the Fire Flow Alternative settings.

When you are finished reviewing the report, Close the Fire Flow Report and save your 
file.
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Note: Another good way to review an automated fire flow analysis is to 
use color coding. If you have a situation where no nodes meet 
the pressure constraints for the needed fire flow, you can color 
code these nodes in the plan view for easy identification.
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Water Quality Analysis

In conjunction with Extended Period simulations, Bentley WaterGEMS is capable of 
performing a water quality analysis to compute water age, constituent concentration, 
or percentage of water from a given node (trace analysis). Using these features, you 
can look at factors such as residence time in tanks, chlorine residuals throughout the 
system, and which tank or reservoir is the primary water source for different areas in 
your system.

This lesson uses the file called Lesson6.wtg located in the Lessons folder.

To open the existing lesson

1. Open Lesson6.wtg.

2. Click OK to the message dialog that comes up about CONNECTED Projects.

3. Click File > Save As. Enter the filename MyLesson6 and click Save.

4. Choose File > Hydraulic Model Properties, and change the Hydraulic Model 
Title to Lesson 6—Water Quality Analysis. 

5. Click OK.

The water distribution system has already been set up for you. It has one reservoir and 
one tank. The system serves primarily residential areas, with some commercial water 
use as well. There are two pumps connected to the reservoir. However, under normal 
conditions, only one pump will be in use. A background drawing has been included 
for reference.

If you would like to turn off the .DXF background, clear the background check box in 
the Background Layers pane.(View > Backgrounds)
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Step 1: Computing Water Age

You will begin by running an age analysis for water in the system, assuming an initial 
age of 0 for all nodes. The water from the reservoir will be an infinite supply of new 
water, so the age of water elsewhere in the system will be a reflection of time from the 
start of the run and how long ago the water left the reservoir. The analysis will be run 
for a 2-week period (336 hours). Based on this model size, 2 weeks should be more 
than adequate to capture the water age in the network.  If the network was much 
larger, you may need to use a longer duration to ensure maximum water age is 
captured. 

1. Choose Analysis > Alternatives .

2. Select Age Alternative and click New  to create a new age alternative.
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3. Name the new alternative Initial Age = 0. Since you are assuming an initial age of 
0 everywhere in the system, you do not need to enter any initial ages.

4. Next, set up a new Scenario to run an Extended Period Simulation incorporating 
the new Alternative.

a. Click Analysis > Scenarios; note that the Existing - Avg Day scenario 
already exists

b. Highlight the Existing - Avg Day scenario and click New > Child Scenario 
and rename it Age Analysis.
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c. Double-click on the new scenario to open the Property Editor. In the Age 
Alternative field select Initial Age = 0, from the drop-down menu.

d. Close the Property Editor.

e. Click Analysis > Options and double click Existing - Avg Day to view the 
settings for this Scenario. Extended Period Analysis (EPS) should already 
be selected as the Time Analysis Type.

f. Set the Calculation Type to Age

g. Enter a Start Time of 12:00:00 AM.

h. Set a Duration of 336 hours.
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i. Set a Hydraulic Time Step of 1 hour.

j. Close the Property Editor and Calculations Options. 

5. Click Analysis > Scenarios and make Age Analysis current by right-clicking it 
and selecting Make Current.

6. Click Compute  and then close the Calculation Summary and Scenarios 
Manager.

7. Select View > Symbology to open the Element Symbology manager. If you are 
using the default workspace configuration, the Element Symbology manager is 
located directly on the left side of the drawing pane. 

8. Right-click on Pipe and select New > Color Coding

9. Select Age (Calculated) as the Field Name.

10. Click Calculate Range and Select Full Range..
72 Bentley WaterGEMS Quick Start Lessons



WaterGEMS Quick Start Lessons
11. Click Initialize to set up a default color scheme. Accept this default scheme.

If you get a message about Bentley WaterGEMS being unable to determine the 
limits for mapping, make sure that Age Analysis is selected in the Scenario drop-
down list, in the toolbar.

12. Click Apply.

13. Click OK.

14. In the Element Symbology manager, right-click on Age (Calculated) and click 
Insert Legend. 

15. Click in the drawing to place the legend

16. Go to Analysis > Times and click the play button to see how water ages in the 
system. 
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17. A good way to check if your network has had sufficient time to reach an equilib-
rium point is to look at Age vs. Time graphs for your elements.

a. Right-click on Tank T-1 and select Graph

b. In the Series Option dialog make sure that Age Analysis is checked in the 
Scenarios column, Tank and T-1 are checked in the Elements column, and 
Results (Water Quality) and Age (Calculated) are checked in the Fields 
column. Uncheck all other boxes. 

c. Click OK.
From the graph, you can see that once a repeating pattern is reached, the age 
of the water fluctuates between approximately 37 and 52 hours in 24-hour 
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periods. Looking at these equilibrium ranges for various nodes can help guide 
you in setting up initial water age values in subsequent runs.

d. Close all open windows.

Step 2: Analyzing Constituent Concentrations

In this portion of the lesson, you will model the change of chlorine residuals in the 
system over time. Bentley WaterGEMS stores information on constituent characteris-
tics in a file called a constituent library. It is recommended to determine actual constit-
uent characteristics from lab and or field testing to use in a water quality model. You 
will add information for chlorine to this library, set up initial concentrations in the 
system, and run the simulation.

1. Choose Analysis > Alternatives.

2. Click the Constituent Alternative and click New.
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3. Name the new alternative Chlorine Injection and double-click to open.

4. Click the Ellipsis (…) next to the Constituent drop-down menu to open the 
Constituents manager.

5. Make sure that the Chlorine Label is highlighted, and enter the data below in that 
dialog box.

6. Leave the Unlimited Concentration check box selected, and click OK.

7. Click Close to exit the Constituent Library. You should now be back in the 
Constituent Alternative Editor.

8. Select Chlorine from the Constituent list box. 

Label Chlorine

Diffusivity 1.2e-9 m2/s 

First Order Wall 
Reaction Rate 

-0.08 m/day 

Bulk Reaction Rate -0.10 (mg/L)^(1-n)/day
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9. On the same Chlorine Injection editor window, go to the PRV and Pump tabs 
and set the Concentration (Initial) for each to 1 mg/l. 

10. Click the Junction tab, and initialize the chlorine concentrations by entering a 
value of 1 mg/l at each junction node. (Right-click the column heading and use 
Global Edit to set the Concentration (Initial) fields.)

11. In the Reservoir tab, enter a Concentration (Initial) value of 2.0 mg/l for the 
reservoir.

12. Set the tank’s Concentration (Initial) to 0.5 mg/l.

13. Close the Editor and the Alternatives Manager.

14. Now, open the Scenario Manager (Analysis > Scenarios) and set up a new 
Scenario in order to run the Constituent Analysis. 

a. Create a new Child off of the Existing - Avg Day Scenario by highlighting it 
and clicking New > Child Scenario. 

b. Enter Chlorine Analysis as the new scenario name. 

c. Double click the newly created Chlorine Analysis scenario to open its Prop-
erty Editor. In the Constituent Alternative dropdown, select Chlorine Injec-
tion.

15. Click Analysis > Options. Double-click Existing - Avg Day to open the Property 
Editor and set the Calculation Type field to Constituent. 
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16. Close the Property Editor and Calculations Options manager.

17. Make Chlorine Analysis the current scenario 

18. Run the Chlorine Analysis Scenario by selecting Compute on the Home or Anal-
ysis tabs, or by clicking the Compute button in the Scenario manager. 

19. Close the Calculation Summary and Scenarios Manager. 

20. Set up color coding for the pipes. This time, color code by Concentration (Calcu-
lated). Scroll through the time steps (Analysis > Times) to view how the concen-
trations change throughout the network. When you look at your results using color 
coding, tables, and graphs, try to discover what better initial values for chlorine 
concentration might be.

Step 3: Performing a Trace Analysis

A trace analysis determines the percentage of water at all nodes and links in the 
system from a specific source node (the trace node). In systems with more than one 
source, it is common to perform multiple trace analyses using the various source 
nodes as the trace nodes in successive analyses. For this analysis, you will perform a 
trace analysis to determine the percentages of water coming from the tank.

1. Select Analysis > Alternatives.

2. Click the Trace alternative to highlight it.

3. Click New.

4. Name the new alternative Trace Analysis for Tank, and double-click it to open 
the alternative editor.

5. In the Trace Element list box, select the tank, T-1. (click the ellipsis button to 
select it from the drawing).

6. Close the editor.

7. Close the Alternatives Manager.
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8. Next, set up a new scenario to run an Extended Period Simulation incorporating 
the new alternative.

a. Select Analysis > Scenarios.

b. Create a new child for the Existing - Avg Day Scenario by highlighting it and 
clicking New > Child Scenario.

c. Enter Trace Analysis as the new scenario name.

d. Double-click the new scenario to open the Property Editor. Change the Trace 
Alternative to Trace Analysis for Tank.

e. Close the Property Editor.

f. Click Analysis > Options. Double-click Existing - Avg Day and change the 
Calculation Type to Trace. 

g. Close the Property Editor and Calculations manager.

9. Make Trace Analysis the current scenario (Analysis > Scenarios).

10. Run the Trace Analysis Scenario by selecting Compute on the Home or Analysis 
tabs, or by clicking the Compute button in the Scenario manager. 

11. Close the Calculation Summary and Scenarios manager.

12. Create pipe color coding to show the trace by going to Element Symbology > 
Pipe > New > Color Coding. Color code by Trace (Calculated). Make sure 
Trace is the only attribute being color coded (Age and Constituent color coding 
should be turned off). As you scroll through the time periods, notice how the 
colors spread outward from the tank during periods when the tank is draining, and 
recede when the tank begins to fill. For more information on reporting features, 
Reporting Results. 

13. Close the open dialog boxes and save this model.
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Darwin Designer to Optimize the Setup of a Pipe 
Network

In this lesson, you use Darwin Designer to optimize the setup of a pipe network.

Step 1: Creating the Darwin Designer Optimization

1. In Bentley WaterGEMS choose File > Open.

2. Browse to the Lessons\Designer folder and open DesignerSample1.wtg.

3. Click OK to the message dialog that comes up about CONNECTED Projects.

4. Go to File > Save As and name the file DesignerSample1Solution
80 Bentley WaterGEMS Quick Start Lessons



WaterGEMS Quick Start Lessons
5. Click Analysis > Darwin > Darwin Designer. 

6. In the Darwin Designer window, click New > New Designer Study. 

7. Highlight the new design and click the Rename button. Enter Tunnel Expansion 
Project. 

8. In the Design Events tab Select Optimization Base as the representative 
scenario in the drop-down list.

9. In the Design Event tab, click New.

10. Name the design event Required Pressures, and click OK.

11. Set pressure constraints for all junctions.

a. First, minimize the Darwin Designer dialog.

b. Create a new selection set containing all of the junctions in the model. Click 
View > Selection Sets. 
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c. Click New > Create From Query. 

d. Double-click the All Junctions query, then click OK. 

e. Rename the new selection set All Junctions. 

f. Back in Darwin Designer, click the Pressure Constraints tab. 

g. Click the Initialize Table from Selection Set button. 
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h. Select All Junctions from the Selection Set drop-down list, then click OK. 

i. In the table in the upper right of the Designer dialog, set the Minimum Pres-
sure (Default) value to 110.33 psi (HGL = 255 ft.). 

j. In the table in the upper right of the Designer dialog, set the Maximum Pres-
sure (Default) value to 1000 psi. For this example, maximum pressure is not 
a consideration, so if you set it to a high value it won’t affect the calculations. 
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12. Customize junction J-17 to require a minimum pressure of 118.03 psi.

a. In the Pressure Constraints area, scroll so you can see junction J-17.

b. Select the Override Defaults? check box.

c. Type a minimum pressure of 118.03 psi., maximum pressure of 1000 psi

13. Click the Design Groups tab. 

14. Click Select Elements for Design Group button  . This button lets you 
automatically create one design group for each pipe in the network or for a partic-
ular set of pipes. 

a. In the Selection Sets drop-down list, select Parallel Pipes for Optimization. 
This highlights a selection set containing a specific subset of the pipes in your 
network. 

b. Click OK.

15. Add an option group for your optimization.

a. Click the Cost/Properties tab. 

b. Highlight New Pipe in the tree-view. 

c. Click New > Design Option Groups. 

d. Name the new table New Pipe Sizes
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e. Type the following pipe material, size, roughness coefficient, and cost:

Material Diameter 
(in.)

Hazen 
Williams C 
Factor

Cost 
($/ft)

Ductile Iron 0 100 0.00

Ductile Iron 60 100 176.00

Ductile Iron 72 100 221.00

Ductile Iron 84 100 267.00

Ductile Iron 96 100 316.00

Ductile Iron 108 100 365.00

Ductile Iron 120 100 417.00

Ductile Iron 132 100 469.00
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16. Create a new optimized design run.

a. In the Designs tree-view, right-click Tunnel Expansion Project and select 
New Optimized Design Run.

Or, click the New button and select New Optimized Design Run.

b. Name the design run Optimized Design.

17. Select the design event you want to use, Required Pressures, by clicking the 
Active check box.

18. Click the Design Groups tab.

a. Make sure the Is Active? check boxes for all of the design groups are 
checked. 

b. Right-click the Cost/Properties column heading. 

c. Select Global Edit. 

d. Choose New Pipe Sizes as the option group you want to use and click OK. .

19. Click the Options tab.
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a. Set the GA Parameters as follows (most of these are the default settings, with 
the exception of Random Seed and Penalty Factor):

b. Set the Stopping Criteria as follows:

c. Set the Top Solutions, Solutions to Keep to 3. This sets how many results will 
be available as results (see Step 2: Viewing Results later in the lesson).

20. Click Compute to calculate the optimized design.

While the calculation proceeds, Bentley WaterGEMS displays the Darwin Designer 
Run Progress dialog box, which displays the following information: 

• Fitness—In this case, you were calculating based on cost. So, the best fitness is 
the least costly solution that the GA (Genetic Algorithm) found. 

• Cost ($)—The lowest cost found by the calculation displays here. 

• Benefit—Measured pressure improvement in the network. This is 0 because the 
lesson only considers cost and not pressure benefit. 

• Violation—The largest violation of established pressure and flow boundaries, 
such as maximum or minimum pressures, displays here. If there were a violation, 
you would use the results area Pressure and/or Flow tabs (in the results pane of the 
main Darwin Designer window) to look for the actual violations. 

GA Parameter Value

Maximum Era Number 6

Era Generation Number 150

Population Size 50

Cut Probability 1.7

Splice Probability 60.0

Mutation Probability 1.5

Random Seed 0.4

Penalty Factor 25,000,000.000

Stopping Criteria Value

Maximum Trials 50,000

Non Improvement Generations 200
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• Generations—The maximum value for generations is determined by the 
Maximum Era Number and Era Generation Number you set in the Options > GA 
Parameters. The actual number of generations that get calculated depend on the 
Options > Stopping Criteria you set. 

• Trials—The maximum value for trials is determined by what you set in Options > 
Stopping Criteria. Note that you can set a number larger than (Maximum Era 
Number)*(Era Generation Number)*(Population Size), but calculations beyond 
that number (for this example, the value is 45,000) are less likely to produce 
significant improvements. 
Also, note that the Messages tab might report you exceeded the maximum number 
of trials. This is usually because Darwin Designer must complete all of the gener-
ations before ending a trial, so it is possible that completing generations will cause 
a few excess trials to be calculated. 

21. After the calculation is finished, click Close to close the Darwin Designer Run 

Step 2: Viewing Results

After you calculate the optimized design results display. You can review results and 
look for violations of parameters.

1. From the hierarchy pane, you can click on the Solutions folder or any of the indi-
vidual solutions for more detail. Select the solution you want to see: Solution 1.  

You can click the Graph button  to view the solutions plotted; each solution 
is color coded; use the color code as a key when viewing graphs. 

Solutions are ranked by fitness, with Solution 1 being the best. 

2. In the Solutions tab, if you scroll down, you can see there are seven pipes that 
changed from the default. These are the pipes that Darwin added to the scenario to 
provide the optimal solution:
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3. The Rehabilitation Groups and Flow results under the Simulated Results tab are 
empty because this lesson does not use those. 

4. Click the Pressure results under the Simulated Results tab. This displays the 
maximum and minimum pressure constraints you set on the junctions and the 
actual pressures calculated by Darwin Designer. 

Step 3: Using Results

After you calculate the optimized design results display. You can use the results to 
create graphs and reports.

1. Solution 1 clearly provides the least expensive solution. Export the solution to 
Bentley WaterGEMS so you can use it. 

a. Select Solution 1 in hierarchy under the Solutions folder. 

b. Click the Export to Scenario button  . The Export Design to Scenario 
dialog box opens. 

c. Select all check boxes to export to the various alternatives. 

d. Name the scenarios you want to export, such as Optimized Design - 1. The 
name you choose must be unique; there cannot already exist a scenario with 
the same name. 

e. Click OK.
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2. Close Darwin Designer.

3. In Bentley WaterGEMS, select the scenario you exported from the Scenario drop-
down list. Notice the parallel pipes that have been added to the base network. 
These are the pipes that meet the optimized design calculated by Darwin 
Designer.
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Darwin Designer to Optimize a Pipe Network

In this lesson, you use Darwin Designer to optimize the setup of a pipe network.

There are three scenarios:

• Existing System representing current system conditions

• Future Condition representing the system expansion layout 

• Optimization Base representing the scenario that Designer will optimize.

There are two design goals:

• New pipes to be sized are pipes 54, 68, 70, 72, 74, 76.

• Old pipes need to be rehabilitated by applying possible actions including cleaning 
pipe, relining pipe, and leaving the pipe as it is (no action or do nothing to a pipe).

The design criteria is:

• Minimum pressure of 45 psi at all demand junctions

• Maximum pressure of 100 psi at all demand junction

• Filling each tank to or above the initial tank level

Getting Started

1. Browse to your Lessons\Designer folder. Open DesignerSample2.wtg.

2. Click OK to the message dialog that comes up about CONNECTED Projects.

3. Go to File > Save As. Name the file DesignerSample2Solution

4. If needed, select Existing System from the Scenario drop-down list. This displays 
the current network. 

Notice that the Existing scenario comprises two types of pipe:

– In green, there are older pipes, perhaps representing an old downtown section

– In purple, there are newer pipes, perhaps representing newer additions to the 
water supply network.

Note: The Future conditions portion of the model may display in gray 
for you.  You can control visibility of inactive elements by 
toggling the "Display inactive topology" setting under Tools > 
More > Options > Global

5. Click Compute to calculate the system pressures and tank levels for the Existing 
Condition.
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If you want, you can inspect the pressures and tank volumes, but the purpose for 
calculating this condition was for a tank level comparison between the Existing 
and Future Condition scenarios in a later step.

6. Close the Calculation Summary and User Notifications windows. 

7. Select the Future Condition from the Scenario drop-down list. If needed, click 
Zoom Extents to view the entire network in the window.
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8. Click Compute to calculate the system pressures and tank levels for the Future 
Condition. 

9. Close the Calculation Summary and User Notifications windows.

10. Review the pressure at junctions using color coding. 

a. Click View > Symbology. By default, Symbology is docked on the left hand 
side of the drawing pane. Right-click on Junction in the list and select New > 
Color Coding. The Color Coding dialog box opens. 

b. Set the Field Name to Pressure. 

c. Click the Calculate Range button and select Quick Range. This gives you a 
quick glance at the pressure ranges for this scenario.
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d. In the Color Maps section, click the New button. Set the Value <= for this 
first row to 45 psi and the Color to Red. Create 3 more rows using the 
following data: 

e. The Color Coding dialog should now look like this: 

Click OK to apply the color coding and close the dialog. 

For this lesson, one objective is to keep the junction pressures above 45psi. So, when 
you run the animation, watch for red junctions which indicate unacceptably low pres-
sure. 

Value <= Color

70 Blue

100 Magenta

130 Green
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11. Run an animation to see what happens in the network over the course of 24 hours. 

a. Click Analysis > Times . 

b. Click Play to run the animation. 

c. Notice, at hour 6 there is a low pressure junction and by hour 12, most of the 
junctions are showing a low pressure. 

12. Use Graphs to check the levels of the tanks. 

a. Right-click the tank labeled 165 and select Graph. 

b. We want the graph to show the water levels for tank 165 in the Existing 
scenario and also the Future Condition scenario. In the Series Options dialog, 
check the box for Existing System in the Scenarios list pane. 
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c. In the Fields list pane, make sure that either Hydraulic Grade or Level 
(Calculated) is selected.
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d. Click OK

e. Notice that by hour 11, Tank 165 is empty and does not refill. 

f. Click the Add to Graph button .
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g. In the drawing pane, click tank 65 then right-click and select the green check-
mark Done. 

h. Notice that by hour 12, Tank 65 is also empty. 

i. Close the graph window.

13. You need to use Darwin Designer and some analysis in Bentley WaterGEMS to 
change the existing pipe network to: 

• Keep junction pressures above 45psi

• Keep the two water tanks filled 
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Set Up for Darwin Designer 

With Darwin Designer, you need to consider two ways of accomplishing a cost-effec-
tive design: create new or parallel pipes and rehabilitate existing pipes. Clearly, the 
new subdivision will get new pipes. And, as you can design an appropriate size for 
these new pipes, there is no need for parallel pipes and there are no existing pipes on 
which to perform rehabilitation.

With that in mind, you would create a parallel pipe option for all existing pipes. This 
parallel pipe option should include a variety of sizes so Darwin Designer has flexi-
bility to choose the most efficient size. Additionally, the pipe sizes must include a 0 
diameter, which lets Darwin Designer calculate the efficiency of the system with the 
pipe absent (without installing the parallel pipe). There are four options in this tutorial 
for existing pipe:

• Install parallel pipe

• Clean existing pipe

• Reline existing pipe

• Take no action

1. Select Optimization Base from the Scenario drop-down list.

This is the future network set up for Darwin Designer optimization. Notice that 
parallel pipes have been added next to all the existing pipes. All new pipes—
parallel and new ones for the subdivision—are colored red.
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2. Click Analysis > Darwin > Darwin Designer. 

3. Create a new designer study, called Design and Rehabilitation. 

a. Click the New button and select New Designer Study. 

b. Rename the study Design and Rehabilitation. 

4. If needed, select Optimization Base from the Representative Scenario drop-down 
list. 

5. Create a new design event, called Criteria Set 1. 

a. In the Design Events tab click New. 

b. Highlight the new design event and click Rename. 

c. Enter the name Criteria Set 1 and click OK. 

6. Set up the Design Event.

a. Scroll to the right and set the default minimum and maximum pressure 
constraints: 
-  Minimum Pressure (Default) to 45 psi 
-  Maximum Pressure (Default) to 100 psi. 

b. Click the Pressure Constraints tab at the bottom. 

c. Click the Select From Drawing button . 
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d. In the Select toolbar, click the Query button and select Network > 

All Junctions. Then select Done . 

e. Note that the Pressure Constraints table now contains entries for each junction 
in the model. 

7. Click the Design Groups tab.

8. Click New to create design groups. You need to create design groups for all new 
or potentially new pipes, which include:

– All pipes labeled in the model with a P (these are parallel pipes)
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– All new pipes: 54, 68, 70, 72, 74, 76

Do not include existing pipes in any of these groups, because these need to be in a 
rehabilitation group.

9. Click the Rehabilitation Groups tab. Create rehabilitation groups containing 
pipes grouped as follows:

– 4, 8, 30, 32, 34 36

– 2, 10, 12, 14, 16, 18, 20, 22, 24, 26, 28, 48

– 6, 78

– 38, 40, 42, 66

– 44, 46, 50, 58, 62, 80

– 52, 56, 60, 64

You might consider grouping pipes based on size or age. To create a rehabilitation 
group:

a. Click New.

b. If desired, rename the Rehabilitation group and click OK.

c. Click the Select Elements for Demand Group button to choose the pipes 
you want to include in the group.
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10. Click the Cost/Properties tab. Create two design option groups and one rehabili-
tation option group..

a. Click New > Design Option Groups to create a new table. 

b. Rename the table Design Cost Table - 1. 

c. Enter the data below into the table. The first table contains a pipe diameter of 
0. All parallel pipes will use this option group. Including a diameter of 0 lets 
Darwin Designer consider not adding a parallel pipe if that pipe is not needed 
for the optimal solution.

Material Diameter 
(in.)

Hazen 
Williams C 
Factor

Unit Cost 
($/ft.)

Aluminum 6 130 12.80

Aluminum 8 130 17.80

Aluminum 10 130 22.50

Aluminum 12 130 29.20

Aluminum 14 130 36.20

Aluminum 16 130 43.60

Aluminum 18 130 51.50
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d. Create a second design costs table. (You can duplicate the table you just 
created and delete the row for 0 diameter.) This table is the same as the first 
one except it does not have a pipe diameter of 0 and is used for new pipes. 
New pipes must have a minimum diameter because their existence is a 
requirement, unlike the parallel pipes.

11. Create a single rehabilitation option groups table containing three actions: Clean, 
Relining, and Do Nothing. A do-nothing action is necessary so Darwin Designer 
can consider not rehabilitating some pipes. Each of these actions must reference 
three functions, one for each column in the table.

Aluminum 20 130 60.10

Aluminum 24 130 77.00

Aluminum 30 130 105.50

Aluminum 0 130 0.00

Material Diameter 
(in.)

Hazen 
Williams C 
Factor

Unit Cost 
($/ft.)

Aluminum 6 130 12.80

Aluminum 8 130 17.80

Aluminum 10 130 22.50

Aluminum 12 130 29.20

Aluminum 14 130 36.20

Aluminum 16 130 43.60

Aluminum 18 130 51.50

Aluminum 20 130 60.10

Aluminum 24 130 77.00

Aluminum 30 130 105.50

Material Diameter 
(in.)

Hazen 
Williams C 
Factor

Unit Cost 
($/ft.)
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12. Click New > Rehabilitation Option Groups to create a new rehabilitation option 
table.

a. Rename the table Rehab Cost Table - 1.

b. Type the name of an action you want to create, such as Clean.

c. Click the cell under Pre-Rehabilitation Diameter Vs. Post-Rehabilitation 
Diameter and click the Ellipsis (…) button to create a new function. The 
Rehabilitation Functions manager opens.

d. Click New > New Pre-Rehabilitation Diameter Vs. Post-Rehabilitation 
Diameter Function.

e. Name the function, Function - 0.

f. Enter your diameter data (inside pipe diameter) into the table on the right side 
of the dialog. We recommend you include all the diameters of pipe in the 
table. (If you do not, Darwin Designer will use interpolation to calculate the 
diameters you do not include.) In this case, the function does not change the 
diameter of any pipes.

13. In the Rehabilitation Function Manager, click New > Pre-Rehabilitation Vs. 
Post-Rehabilitation Unit Cost.

a. Rename it Function - 1.

b. Enter the data for pipe diameter and unit cost as follows:

Pre-Rehabilitation 
Diameter (in.)

Post-
Rehabilitation 
Diameter (in.)

6 6

8 8

10 10

12 12

14 14

16 16

18 18

20 20
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14. In the Rehabilitation Functions manager, click New > Pre-Rehabilitation Diam-
eter Vs. Post-Rehabilitation Roughness Function.

a. Rename it Function - 2, and click OK.

b. Enter the data for pipe diameter and roughness as follows:.

15. Create another Function called Cost Function - Reline. This is the cost for 
relining pipes. Use these values:

Diameter (in.) Unit Cost($/ft.)

6 17.00

8 17.00

10 17.00

12 17.00

14 18.20

16 19.80

18 21.60

20 23.50

30 25.50

Diameter (in.) Unit Cost($/ft.)

6 130

8 130

10 130

12 130

14 130

16 130

18 130

20 130
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16. Create a final function called Cost Function - Do Nothing. This function is 
required if you need Darwin Designer to consider not rehabilitating an existing 
pipe as an option.

Diameter (in.) Unit Cost ($/ft.)

6 26.20

8 27.80

10 34.10

12 41.40

14 50.20

16 58.50

18 66.20

20 76.80

24 109.20

30 142.50

Diameter (in.) Unit Cost ($/ft.)

6 0.00

8 0.00

10 0.00

12 0.00

14 0.00

16 0.00

18 0.00

20 0.00

24 0.00

30 0.00
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17. The Rehabilitation Functions manager should now look like this: 

18. Click Close to close the Rehabilitation Functions manager.

19. For the Action: Clean:

a. Set the Pre-Rehabilitation Diameter vs. Post-Rehabilitation Diameter Func-
tion to Function - 0.

b. Set the Pre-Rehabilitation Diameter vs. Unit Cost Function to Function 1. 

c. Set the Pre-Rehabilitation Diameter vs. Post-Rehabilitation Roughness Func-
tion to Function 2. 

20. Type a new Action, called Relining 1.

a. Set the Pre-Rehabilitation Diameter Vs. Post-Rehabilitation Diameter Func-
tion to Function - 0.

b. Set the Pre-Rehabilitation Diameter Vs. Unit Cost Function to Cost Function 
- Reline.

c. Set the Pre-Rehabilitation Diameter Vs. Post-Rehabilitation Roughness Func-
tion to Function - 2.
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21. Type a new Action called Do Nothing.

a. Set the Pre-Rehabilitation Diameter Vs. Post-Rehabilitation Diameter Func-
tion to Function - 0.

b. Set the Pre-Rehabilitation Diameter Vs. Unit Cost Function to Cost Function 
- Do Nothing.

c. Set the Pre-Rehabilitation Diameter Vs. Post-Rehabilitation Roughness Func-
tion to Function - 2.

22. Click the Design Type tab to set the genetic algorithm parameters. Set the Objec-
tive Type to Minimize Cost. You are not considering any benefits to increasing 
system flow or pressure.
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Create the Optimized Design Run

The design run uses your setup and applies it to the network.

1. Right-click the Design and Rehabilitation design run in the left pane, and select 
New > New Optimized Design Run.

2. Name the optimized design run as Design Run -1.

3. In the Design Events tab, select the Is Active? check box for the Design Event 
Name Criteria Set 1. This enables the selected design event for the current run.

4. Click the Design Groups tab.

5. Make sure the Is Active? check box is checked for all of the design groups. 

6. Select the design option group used by your design groups. 

a. All groups containing parallel pipes need to use Design Cost Table 1, for that 
option group contains data for a pipe size of 0. Parallel pipes have the prefix 
P. 

b. All groups containing new, single pipes need to use Design Cost Table 2, for 
that option group does not use a 0 pipe size. 
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7. Click the Rehabilitation Groups tab.

a. Make sure all the groups are checked as Is Active.

b. Set all the groups to use your rehabilitation option group. (Right-click the 
heading of the check box column and globally edit them.)

8. Click the Options tab to set the GA parameters for the optimization.

– Under Stopping Criteria, set Maximum Trials to 100000.

– Under Top Solutions, set Solutions to Keep to 5.
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Calculate and Verify the Optimal Solution

After you calculate your solutions, it is important that you look at them and verify they 
do what you need.

1. Click Compute. A dialog box opens that displays the progress and certain statis-
tics of the calculation.

2. After the calculation is complete, click Close. (If the calculation did not complete 
successfully, you would check the Messages tab.)

Under the Solutions folder you see five solutions numbered 1 through 5 These are 
the five top solutions Darwin Designer has calculated. Highlight the Solutions 
folder to display a summary of each of the top solutions. 

Solutions are stored in order of optimization fitness, with Solution 1 providing a 
better calculated solution than Solution 2, which has a better calculated solution 
that Solution 3, etc.

3. Export the solutions to your model, so you can review tank levels. 
112 Bentley WaterGEMS Quick Start Lessons



WaterGEMS Quick Start Lessons
Note that the optimization calculations consider your pressure requirements (that 
pressure be greater than 45 psi) but not your tank levels.

a. Highlight Solution 1

b. Click Export to Scenario. The Export to Scenario dialog box opens.

c. Select the Use Scenario Name for Alternatives check box. The default name 
is the design run name plus an incremental number starting at 1.

d. Check the Export Physical Alternative? and Export Active Topology 
Alternative? checkboxes.

e. Click OK. This exports Solution 1. 

f. Select Solution 2 from the solutions list.

g. Export Solution 2.

h. Export the remaining solutions as it was done in steps ‘b’ through ‘d’ above.

4. Close Darwin Designer so you can review the solutions you exported.

5. Click Analysis > Scenarios to open the Scenarios manager. .
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6. Compute the scenarios you exported in a batch run. This lets you graph those 
results and look at what is happening with your tank levels.

a. Click the black down arrow next to the compute button at the top of the 
scenario manager and choose Batch Run.

b. Select the Scenarios you want to run. (Design Run - 1 - 1, Design Run - 1 - 2, 
Design Run - 1 - 3, Design Run - 1 - 4, and Design Run - 1 - 5).

c. Click Batch, click Yes in the prompt, and close the message boxes that appear 
before and after the calculations. 

d. After the batch run finishes, close the Scenarios manager and the User Notifi-
cations dialogs.

7. You will use graphing to inspect your tank levels. Click View > Graphs

e. Click the New button and select Line Series Graph. A Select toolbar appears 
to allow you to select the elements you want to graph from the drawing view. 
Click on both tanks, then select Done. 

f. In the Scenarios list of the Series Options dialog, check the boxes next to the 
Design Run - 1 - 1, Design Run - 1 - 2, Design Run - 1 - 3, Design Run - 1 - 
4, Design Run - 1 - 5, and Future Condition scenarios (uncheck Optimized 
Base if it is checked). 
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g. In the Fields list make sure Hydraulic Grade or Level (Calculated) is 
selected.
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h. Click OK

i. Review the graph. Notice that each of the design runs are able to keep the 
tanks full. 

j. While all of the design runs do keep the tanks full, Solution 1 is the best 
optimal solution that meets your pressure and tank fill requirements while 
minimizing costs. 

8. Close the Graph window. 

9. In the Scenario drop-down list, choose Design Run - 1-1, which represents Solu-
tion 1 that Darwin Designer calculated. From looking at the results in the graph, 
you know this solution keeps your tanks full.
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10. Inspect your tank pressure by animating the scenario over 24 hours. Click Anal-
ysis > Times. Click Play.

Note the color coding for pressure:

– <= 45 psi is red

– <= 70 psi is blue

– <= 100 psi is magenta

– <= 130 psi is green

11. Make sure none of the junctions is red during the animation.

12. Inspect a graph of junction pressures.

a. Click Home > Select by Element > Junction to select all of the junctions.

b. Right-click one of the junctions and select Graph. Click Yes to the prompt 
asking if you want to graph all of the selected elements. 
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c. In the Series Options dialog, uncheck the Hydraulic Grade Field and check 
the Pressure box. 

d. Click OK.
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The Graph dialog box opens and displays pressures for the junctions you selected. 
Note that none of the junctions fall below 45 psi.

Darwin Designer computed Solution 1 to be the most optimal solution, meaning the 
least costly, and it also kept the tanks full. You also verified that Solution 1 was able to 
maintain pressures above 45 psi.
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Scenario Energy Costs

Scenario Energy costs calculates energy usage and cost based on an extended period 
simulation (EPS). It also determines a number of intermediated values such as effi-
ciency, power, and peak energy use.

Steps for running an energy cost calculation

1. Run EPS simulation.

2. Open energy cost manager and set up energy pricing.

3. Select scenario and run energy cost calculation.

4. Review Results.

Step 1: Run EPS Model

1. Open the EngCostLessonStart.wtg file in the Lessons directory.

2. Click OK to the message dialog that comes up about CONNECTED Projects.

3. Compute the EPS Scenario in the model .
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4. Choose View > Graphs and double-click on PMP-1 .

Notice that the pump reaches 100% full speed several times.
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5. Close the graph. In the Graphs manager, double-click the Tank Levels graph
.

The tanks fill gradually during this run and empty slightly quicker when the main 
PUMP cycles off.

6. Close the graph.
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7. In the Graphs manager, double-click the Pump Graphs.

You can see the relative flow of the main pump and the booster bump.

8. Close the graph and the Graphs manager.

9. Save the file as MyLesson9.wtg

Step 2: Setting up energy pricing

1. Choose Analysis > Energy Cost > Scenario Energy Cost.

2. Click Energy Pricing .
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3. Set the start energy price to 0.10 $/kWh. Use the Add icon on the right side of the 
dialog to add entries to the energy price table and enter the energy price data 
shown in the table below.

4. Click Close.

5. In the Scenario Energy Cost manager, select EPS from the Scenario menu.

Time From 
Start

Energy Price 
($/kWh)

12 0.15

21 0.10

24 0.10
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6. In the Pumps tab, check the Include in Energy Calculation? boxes for each of 
the pumps. Select Energy Pricing -1 in the Energy Pricing column for all pumps.

7. Click the Tanks tab. Make sure the Include in Energy Calculation? boxes are 
checked for both tanks.

Step 3: Run the energy cost analysis

1. In the Scenario Energy Cost manager, click Compute .

2. Highlight the Pump/Turbine Usage entry in the list. You can see that the effi-
ciency of the constant speed PUMP is higher than that of the variable speed PMP-
1 and PMP-2 was not called during this run. 
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3. Highlight PMP-1 and click the Graph tab. Change the attribute being graphed to 
Cost per Unit Volume and see how the cost changes as a result of pump status 
and time of day energy charges. 

4. Close the Energy Cost manager.

Step 4: Making graphical comparisons between pumps

1. In the drawing, select PMP-1 and then, while holding down the <Ctrl> key, click 
on the PUMP element. Right-click and select Graph to open the Series Option 
manager.

2. Un-check the Flow (Total) checkbox and expand the Results (Energy Costs) 
category (click the + button) 
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3. Check the Wire to Water Efficiency and Cost per Unit Volume boxes. 
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4. Click OK to open the graph.

The efficiency of the constant speed pump is higher than the variable speed pump 
whenever it is on. The cost per volume pumped is comparable since the PUMP 
usually pumps against a higher head. In order to view the head attribute, click on 
Series Options and check the Pump Head box under the Results folder. 

5. PUMP pumped into a pressure zone that required a higher pump head.

6. Click the Add to Graph Manager button to save the graph, enter a name and 
click OK, and then close the graph window. 
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Pressure Dependent Demands

Pressure dependent demands (PDD) are used to simulate situations where a change in 
pressure affects the quantity of water used.

To use PDD

1. Set up a model.

2. Create a PDD function.

3. Create a scenario that assigns a PDD function to an alternative.

4. Run the scenario.

This lesson uses the example of a neighborhood that receives water from two sources, 
reservoirs that are near and far and both have a hydraulic grade of 150 ft. In this 
lesson, you will simulate the system without considering PDD and all elements oper-
ating. Then the analysis will be run with PDD. In order to simulate a situation where 
pressure significantly drops, the Near source is taken out of service and the behavior 
with and without consideration of PDD is made.

The starter file consists of a model with two non-PDD scenarios, SteadyNoPDD and 
EPSNoPDD. The demands have been loaded and the diurnal demand function has 
been created.

Step 1: Run the initial NoPDD Model

1. Open the PDDLessonStart.wtg file in the Lessons directory.

2. Click OK to the message dialog that comes up about CONNECTED Projects.

3. Go to File > Save As and name the file MyPDDLesson.
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4. The Near source is on the left and the Far source is on the right.

5. Verify the current scenario is SteadyNoPDD.

6. Compute the model  and make sure results are green, then close the Calcu-
lation Summary.
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7. Click Report > Junction. 

Note that the pressures range from 43 to 60 psi.

8. Close the FlexTable.

9. Make EPSNoPDD the current scenario.

10. Compute the scenario  , make sure results are green, then close the Calcula-
tion Summary.

11. In the drawing, hold the <Ctrl> key and click the Near reservoir, then the Far 
reservoir, and then right-click and select Graph. 
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12. Uncheck Hydraulic Grade, then check Flow (Out net) and then click OK to 
view the graph.
132 Bentley WaterGEMS Quick Start Lessons



WaterGEMS Quick Start Lessons
13. Click Add to Graph Manager  to save the graph and name it SourceFlow.

14. Click OK and then close the graph.

15. If you want to turn off the background layers of the drawing choose View > Back-
grounds and turn off PDD Background.

and the drawing will look like the following:
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Step 2: Setting up PDD function

1. Choose Components > More > Pressure Dependent Demand Functions. Click 
New and then rename to PowerFunc.

2. Has Threshold Pressure? should be checked and type in 40 psi for the pressure 
threshold.

3. Close the PDD Function manager.

4. Choose Analysis > Alternatives and click the Pressure Dependent Demand 
Alternative and double-click the Base Pressure Dependent Demand Alternative 
to edit it..
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5. Select PowerFunc from the Global Function menu

6. Click Close.

Step 3: Run the model with PDD

1. Choose Analysis > Scenarios and create a child scenario of EPSNoPDD.

2. Right-click on EPSNoPDD > New > Child Scenario and rename it EPS-PDD

3. Double-click on the EPS-PDD scenario to open the Scenarios Property Editor. 
Under Calculations Options, click the Steady State/EPS Solver Calculation 
Options menu and select New. Rename the new option EPS-PDDCalc and then 
click OK..

4. Make EPS-PDD the current scenario.
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5. Choose Analysis > Options and double-click on EPS-PDDCalc to open the 
Property Editor.

6. Set Time Analysis Type to EPS
Set Use Pressure Dependent Demand? to True.
Set Pressure Dependent Demand Selection to <All Nodes>

7. In the Scenarios manager, make sure the EPS-PDD scenario is current, then click 
Compute. 

8. Review the calculation summary and then close it.

9. Review the results by plotting a graph of flow vs. time. Choose View > Graphs 
and double-click on SourceFlow graph.
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10. Click Series Options  and check both EPSNoPDD and EPS-PDD Scenarios 
and then OK.

There are four lines on the graph but only two are visible. This is because the lines 
for both scenarios are identical.
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11. Click the Data tab to see that the pressure did not drop below the reference pres-
sure during the run.

Step 4: Running non-PDD models with outage

In order to examine the effect of a drop in pressure, create a scenario where the pres-
sures will drop. In this example, Near tank will be taken out of service. Create a new 
scenario where pipe P-2 is closed.

1. Click Analysis > Alternatives . Expand the Initial Settings Alternative node and 
right-click the Base Initial Settings Alternative. Select New > Child Alterna-
tive. 

2. Rename to Near Tank Out

.
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3. Double-click on Near Tank Out and change the status of P-2 to closed. When the 
status has been changed to Closed a check shows in the first column to show that 
it is different from its parent.

4. Close the alternative editor.

5. In the Scenarios Manager create a new child scenario off of EPSNoPDD called 
TankOutNoPDD.

6. Double-click the new scenario to open the scenario Property Editor. Change the 
Initial Alternative to Near Tank Out and then close the Property Editor.
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7. Make the TankOutNoPDD the current scenario and then click Compute.

8. Review the calculation summary and then close it.

9. Right-click on J-12 and select Graph. 
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10. In Series Options check the boxes for the EPSNoPDD and TankOutNoPDD 
scenarios. Check the box next to the Pressure field (Hydraulic Grade is checked 
by default; leave it checked) and click OK.

When the Near Tank is out of service there is a significant drop in pressure.

11. Examine the effect of the drop in pressure on Demand. Click the Series Options 
button. In the Graph Series Options manager check Demand and then OK. 
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12. The demand did not change with pressure because it is not a PDD run, demand is 
independent of pressure, so there is a single line for Demand. Notice that when 
flow increases due to the time of day, there is not a corresponding drop in flow 
because of pressure drop.

13. Click the Add to Graph Manager button, rename the graph as Pressure 
Demand J-12 and click OK.

14. Close the graph.
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Step 5: Run PDD model with outage

1. Click Analysis > Scenarios. 

2. Right-click EPSPDD and select New > Child Scenario. Rename the new 
scenario TankOutPDD. 

3. Double-click on TankOutPDD to open the scenario Property Editor.

4. Set the Initial Settings alternative to Near Tank Out

5. Close the Property Editor and make the TankOutPDD scenario current.

6. Compute the scenario, review the calculation summary, and close it. 

7. Click View > Graphs and open the Pressure Demand J-12 graph. 
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8. Click the Series Options button   and check TankOutPDD in the list of 
Scenarios, uncheck Hydraulic Grade in the list of Fields, and then click OK. 
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9. When PDD is used, the demand decreases when the pressure drops, so the overall 
pressure drop is not as great as when the pressure dependency of demands is 
ignored.

10. Close the graph.

Step 6: Animating Results

1. Click Analysis > Scenarios and make the TankOutNoPDD scenario current.

2. Choose View > Symbology and expand the Junction entry

3. Right-click on Junction and then select New > Color Coding.
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4. Select Pressure from the Field Name menu and Color and Size from the Options 
menu.

5. Click Calculate Range , select Full Range from the submenu, this gives you the 
pressure ranges for this scenario.

6. Click the Initialize button
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7. Manually modify the ranges, color and size fields to look like the following 
example. The colors, in order of appearance are: Red, Magenta, Yellow, Green, 
and Royal Blue. Change the sizes to 3, 3, 2, 2, and 1 respectively.

8. Click OK.
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9. Click Analysis > Times and click Play . Observe how the colors and pressures 
change over the course of a day. Then click Pause .

10. Switch to the TankOutPDD scenario.

11. Compute, and then close the calculation summary.

12. Click Play and observe how the pressures in this run do not drop as low.
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13. Pause the animation and click View > Backgrounds and check the PDDBack-
ground box. 
.

14. Close the open dialogs. 
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Criticality and Segmentation

A criticality analysis can be performed on a water model to identify the most critical 
or important hydraulic elements within the model. Once the options have been set in a 
Criticality Studies level of the Segmentation and Criticality manager, you must decide 
which scenario is to be used for the analysis and set the rules for use of valving in the 
options tab.

This lesson assumes that you have already constructed a model that has isolating 
valves and that these valves reference pipes and pressure dependent demand functions 
that have been set up.

Step 1: Check the Isolation Valves

1. Open CritStart.wtg from the Lessons folder

2. Click OK to the message dialog that comes up about CONNECTED Projects.

3. Go to File > Save As and name the file MyCritSolution.

4. Use Pan to look at the placement of isolation valves (or hold the middle 
mouse button to pan)

5. Click Home > Find Element  (The top section of the Property Editor 
contains the Find Element tool). Type J-11 in the field and then click Find.
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6. Check for valves not assigned to pipes. 

a. Click View > Queries. Under Queries - Predefined, expand the Network 
Review folder and double-click Orphaned Isolation Valves. 

b. All valves are assigned, however if the query turned up orphaned valves then 
you could delete the isolation valve, leave it orphaned, or select the valve and 
choose the Referenced Pipe option in the valve Property Editor and select the pipe 
where the valve is located.

7. Close the queries manager and the Property Editor.
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Step 2: Start the Criticality Manager and set up segmentation

1. Choose Analysis > Criticality 

2. In the Options tab, verify that Consider Valves? is checked and that Always Use 
is selected in the Isolation Valve field.
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3. Click New. In the Add Scenario dialog, check Avg. Daily Demand and click OK. 

4. Select Entire Network from the Scope Type menu.

5. Click Compute  to perform the segmentation analysis, and click Yes at the 
prompt.

Label - List of segments that were identified in the analysis. If Consider Valves? 
was not checked, there is one pipe per segment and the label of the pipe is listed 
next to the segment name. In this case, Consider Valves? was checked so the 
segments consist of a variety of pipes and nodes.

General statistics are given for each segment.

Affected Elements - The elements that make up or bound the segment.
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6. Click Highlight Segments  to view the color coded segments in the drawing.

The results of segmentation can be advantageous. You can identify which 
segments require successful operation of a large number of valves in order to 
achieve a shutdown.

7. Right-click on the Isolation Nodes <Count> column and select Sort > Sort 
Descending.

The segments at the top of the list usually prove to be the most difficult to isolate 
and may require investigation to make them less susceptible to issues that arise 
due to an inoperative valve.
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Step 3: Perform outage analysis to identify if isolating a segment 
causes other segments to be isolated

1. Click on Outage Segments and then Compute .. Click Yes at the prompt.

2. Right-click on Outage Set Length > Sort > Sort Descending to find out which 
segments have outages that will cause significant downstream outages.
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3. Select the Outage Segment with the highest Outage Set Length from the Label 

column. Click Highlight Segments  to view the color coded segments in the 
drawing. 

4. View the drawing to see that the pipe with the highest Outage Set Length is in blue 
and the downstream outage segments that will be out of service are in red.
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Step 4: Run criticality analysis

The most important function of criticality analysis is the ability of the system to meet 
demands given a segment outage. A form of this analysis is the case where the short-
falls are determined solely based on connectivity. If the node is connected back to the 
source, it is assumed the demands are met. This type of run does not involve the 
hydraulic engine and is calculated more quickly.

1. Select Criticality and make sure Run Hydraulic Engine? is unchecked. Then 

click Compute .
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2. Right-click on the System Demand Shortfall % column and then Sort > Sort 
Descending.

3. Select the segment with the highest System Demand Shortfall from the Label 

list and then click Zoom to Segments .
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4. Now run a criticality analysis that uses the hydraulic network engine to determine 
the impact of segment outages. Check the Run Hydraulic Engine box and click 

Compute .

The System Demand Shortfall % are the same as the run without hydraulic 
calculations. This is because the flows are delivered to all nodes that are 
connected regardless of the pressure. 
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Step 5: Run criticality analysis hydraulic with PDD

While other types of runs can indicate which segment outages cause the most demand 
to be isolated from the system, they are not the way to determine the impact on nodes 
that remain connected to the source but receive much less flow due to the outage. 

In order to make these calculations, the demand in the system must be modeled using 
pressure dependent demands (PDD). 

1. Close the criticality manager and click Components > More > Pressure Depen-
dent Demand Functions.

2. Set the Pressure Threshold to 40 psi and then close the PDD Function manager.
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3. Choose Analysis > Alternatives , expand the Pressure Dependent Demand 
Alternative and select PDDfunction.

4. Double-click to open PDDfunction to verify which PDD function is being used, 
that the reference pressure (the pressure at which all demand is met) is equal to the 
threshold pressure, and that 100% of the demand is pressure dependent.

5. Close the alternative editor and the Alternatives manager. 

6. Click Analysis > Criticality. Highlight Criticality Studies and click the New 
button. Check the box for AveDayPDD. 

7. Click OK.
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8. From the Segmentation Scope tab, Select Entire Network from the Scope Type 
menu..

9. Select AveDayPDD and click Compute .. Click Yes in the prompt that 
appears.

The segmentation results are the same as the first scenario because the same 
valving is used.

10. Select Criticality below AveDayPDD and check Run Hydraulic Engine? and 

click Compute . 
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11. Right click on the System Demand Shortfall column and select Sort > Sort 
Descending.

Notice that the shortfalls have increased over the previous runs because the runs 
that incorporate PDD account for the impact on nodes that receive water but at a 
lower pressure than under normal circumstances.

12. Close the Criticality manager.
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Flushing 

In this Quick Start lesson, you will set up and run a series of conventional flushes (no 
valve operation) and one unidirectional flush. 

1. Open the model called QuickStartFlush.wtg in the Lessons folder.

2. Click OK to the message dialog that comes up about CONNECTED Projects.

3. Click File > Save As and name the file MyQuickFlushSolution.

4. Zoom to the south west portion of the model View > Zoom >  Zoom Window

so that it looks like below:
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Step 1: Conventional Flushing

1. Pick Analysis > Flushing. This opens the flushing manager dialog. 

2. Pick Avg. Daily Demand as the Representative Scenario in the right pane. 

3. In the left pane, highlight Base Flushing, pick the Rename button (third from left 
on top) and change the name to Conventional. 

4. In the right pane, create a pipe set for which you will calculate flushing properties 
by picking the ellipsis button next to Pipe Set, and Select From Drawing. Select 
the pipes shown below. (It may be necessary to zoom in to some of the shorter 
pipes to select them.) 
Bentley WaterGEMS Quick Start Lessons 165



Flushing
5. Pick the green check mark to complete the selection. 

6. Click OK. 

7. Set the Flow Emitter Coefficient to 150. The dialog should look like this: 

8. Click the Events tab on the right pane.

9. Right-click on Conventional in the left pane. Select Add > New Conventional 
Events (Batch)
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10. Select hydrants H-1 through H-8 and click the green check mark. 

The Flushing Manager will look like this: 

11. Run the 8 events in sequence by clicking the Compute button. Close the Calcula-
tion Summary.
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12. To check the results, open the Flushing Results Browser by clicking Analysis, 
then click the down arrow below Flushing and select Flushing Results Browser. 

The Flushing Results Browser shows the effect of each event. 

13. Close this Browser and open the Flushing Area Report by clicking Analysis, then 
click the down arrow below Flushing and select Flushing Area Report. 
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14. Right click on the Velocity Maximum Flushing column and Sort > Descending. 
This table shows the Velocity and Shear Stress for the pipes in the Pipe Set. 

All 24 pipes in this conventional flushing study exceeded the Target Velocity of 
1.5 ft/s.

15. Close the Flushing Area Report.
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Step 2: Unidirectional Flushing Event

Next you will set up a unidirectional flushing event to increase the velocity in a run of 
pipes along the southwest edge of the system. 

1. Highlight Flushing study in the left pane, right-click and Select Add > New Area

2. Rename the new area Uni-SW. 

3. Pick Avg. Daily Demand as the Representative Scenario, set the Emitter coeffi-
cient to 150 and create the Pipe Set as shown below:
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4. Click the green check mark and view the Pipe set. 

5. Click OK. 

6. Right-click on Uni-SW in the left pane. Select Add > New Unidirectional Event.
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7. In the Select dialog that comes up, click the Add Operational Elements button 

. Then pick the valves ISO-34, ISO-35, ISO-36 and ISO-37 to close and 
hydrant H-5 to flow as shown below: 

8. After picking the elements and clicking the green check mark, review the list of 
elements to be operated. Feel free to add some descriptive notes to the elements to 
be operated.

9. Identify the pipes to be part of the Pipe Run by picking the Select from Drawing 
button on the right pane. 
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10. In the Select dialog that comes up, click the Add Pipe Run Elements button 

. Then pick the pipes P-5, P-6 and P-9 as shown below: Once again, it may be 
desirable to use the mouse wheel to zoom in to the shorter pipes.

11. With all of the elements identified, select the Compute button. Click Yes to the 
Compute Single Flushing Event prompt.
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12. Once the run is complete, open the Flushing Results Browser by clicking the 
down arrow to the right of Compute and selecting Show Flushing Results 
Browser.  and view the results

13. Make sure the whole row for the event is highlighted (as shown above), then click 

the highlight button  (second from left) and view the event in the drawing. 

14. Close the Flushing Results Browser
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15. Open the Flushing Area Table by clicking the down arrow to the right of 
Compute and selecting Show Flushing Area Table and view the results

Notice that the velocity in Pipes P-5, P-6 and P-9 exceeds 8 ft/s.

16. Click the down arrow next to Field Report and select Flushing Area Field 
Report (“Uni-SW”). 
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A report is generated including a map of the area and a tabular description of the event 
indicating which elements to operate. 
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You performed a conventional flushing analysis (no valve operation required) and 
confirmed that all pipes in the area of interest met a minimum velocity of 1.5 ft/s. A 
second, Uni-directional flushing analysis, was performed to evaluate the increase in 
velocity for a run of pipes (P-5, P-6, P-9) in the same area. Four valves were closed 
and hydrant H-5 was flushed. Velocity for those pipes increased to over 8 ft/s.

17. Close the report to get back to WaterGEMS.
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Importing SCADA Data

In this lesson, you will import historical SCADA data that has been stored in an Excel 
file and compare the historical values from that file with the current model scenario. 
To accomplish this, you will

- Identify SCADA Data Source
- Import SCADA data
- Create SCADA Elements
- Link SCADA data and modeling elements
- Compare SCADA data with model results

The SCADA data is stored in the Excel file SCADA1.xls in the Lessons folder. 

1. Open the SCADA1.xls file to view its format, which is called multiple rows per 
record. Each record contains a time stamp (24 hour format), pump flow and tank 
hydraulic grade. In case you don’t want to open Excel file, the first few rows of 
the file look like this.:

2. This Excel file is a 32-bit file. Therefore, it is best to use a 32-bit version of 
WaterGEMS. If you are running a 64-bit version, close WaterGEMS and start 
C:\Program Files (x86)\Bentley\WaterGEMS\WaterGEMS.exe
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3. The welcome dialog should indicate 32-bit.

4. Click Open Existing Hydraulic Model and navigate to SCADADa-
taStarter.wtg in the Lessons folder.

5. Click OK to the message dialog that comes up about CONNECTED Projects

6. After you have opened the file, click File > Save As. Name the file MySCADA-
DataSolution.

7. This is a simple model with one pump and one tank as shown below.
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8. Pick Scenario EPS48 and Compute. View the calculation summary graph by 
clicking on the Graph button at the top of the Calculation Summary dialog (third 
button on top of calculation summary). It should look like this.

9. Review the data then close the Calculation Summary graph, and Calculation 
Summary.
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Identify SCADA Data Source

1. Open SCADA Signal Manager using Analysis > SCADAConnect Simulator > 
SCADA Signals.

2. Click New > Database Source. The following dialog opens

3. Click the Edit... button in front of Connection

4. In the Database Connection Dialog that comes up, set Data Source Type to 
Excel2007/2010/2013 (12.0)
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5. Set Data Source to SCADA1.xlsx. in the Lessons folder.

6. Pick Test Connection. It should respond Connection Succeeded.

7. Click OK, then close the Database Connection edit dialog.

8. Back in the Database Source manager, set the following:

– Table name: Sheet1$

– Source format: Multiple values per row

– Time Stamp Field: Time (hours)

– Options: Hstorical

– Time Tolerance: 30 min.
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9. Click Select SCADA Signals to identify which SCADA signals you want to use. 
In this case it is both values. Add them by clicking on each of them. 

10. Click OK to leave signal selection.

11. Click OK to leave Database Source setup. This brings you back to SCADA 
Signals manager.
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View SCADA Data in WaterGEMS

1. Click PMP-1 and set Start to 9/12//2016 12:00 am and End to 9/14/2016 12:00 
am and select Refresh
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2. Pick T-1 and repeat the above steps.

3. You have now imported the data. You must now associate that data with a model 
element using a SCADA signal element. Click OK.
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Creating and Mapping SCADA Signal Elements.

1. Place two SCADA elements using Layout > SCADA Element near the tank and 
pump as shown below.

2. Make sure the labels in your model match the labels in this lesson.
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3. Associate the signals to the pump using the SE-1 Property Editor as shown below, 
by double clicking on SE-1"

– Model Element: PMP-1

– Field: Flow

– Historical Signal: PMP-1 - EPS48 - Flow (Total) (L/s)

– Active Alarm: None
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4. Associate the signals to the tank using the SE-2 Property Editor as shown below:

– Model Element: T-1

– Field: Hydraulic Grade

– Historical Signal: T-1 - EPS48 - Hydraulic Grade (m)

– Active Alarm: None

5. Note the Historical signal values.

6. Close the Property Editor
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Compare Model and SCADA Data

1. Compare calculated model results with SCADA data by graphing each SCADA 
element. Select both signal elements, SE-1 and SE-2, right click and Select 
Graph.

2. Leave the default fields and click OK.

3. Note that the SCADA values (points) compare well with the calculated model 
results (lines).
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SCADAConnect Simulator 

In this lesson, you will simulate a fire event and the response in a water system using 
the simple user interface in SCADAConnect Simulator. You will make three runs: no 
fire, fire and fire response.

1. Start WaterGEMS and open the file SCADASimStart.wtg in the Lessons folder. 
It should look like the model below.

2. Click OK to the message dialog that comes up about CONNECTED Projects.

3. Click File > Save As. Name the file MySCADAConnectRun

PMP-1 controls are based on the level in tank T-1. PMP-2 is a standby pump.

4. Change the existing EPS48 scenario into a SCADAConnect simulator scenario by 
selecting Analysis > Options > EPS48. Change the Calculation Type to SCAD-
AConnect Simulator, then close the Property Editor, and Calculation Options 
manager.
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Be sure to occasionally save your file 

5. Open SCADAConnect Simulator using Analysis > SCADAConnect Simulator 
> SCADAConnect Simulator. Review the manager that appears.

6. Run a normal day by selecting the Compute button on the EPS48 Baseline 
Scenario.
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7. The graph of the Calculation Summary (third button on top of Calculation 
Summary) should look like this.

8. Close the graph and the Calculation Summary.
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9. Open the graph View > Graphs > Tank-Pump which should look like this where 
the red and green lines are pump flows, the blue line is system demand and the 
magenta graph is tank hydraulic grade line.

10. Close the graph and the Graphs Manager.
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Simulating a Fire Response

Next you will simulate a fire flow at J-4 of 25 L/s from 11 am to 3 pm on 9/12/2016. 

1. Back in the SCADAConnect Simulator, click the Emergency Response tab, 

then the Fire Response icon. 

2. Select junction J-4 from the drawing and complete the dialog as shown below.

3. Click OK.
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4. The SCADAConnect Simulator dialog will show the fire flow.

5. Click Compute. Close the Calculation Summary.

6. Notice that a flame has been placed on J-4 (in the drawing) to indicate the location 
of the fire simulation.
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7. After the run, select View > Graphs and create a New graph. Select PMP-1, 
PMP-2 and T-1 from the drawing. Click the green check mark to complete the 
selection. Leave the default graph fields (Flow for Pumps and HGL for Tanks) and 
click OK. 

8. The graph will look like this.

Notice that the HGL in the tank will drop very low, near the tank bottom at 100 m.

9. Close the graph and Graphs Manager.This graph will be automatically saved as 
Graph -1.
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You would like to prevent the tank level from dropping this low. To do this, you will 
turn on pump PMP-2 at ll:00 am and leave it on during the fire. To do this, you will 
need to override the pump control for PMP-2.

10. Back in the SCADAConnect Simulator, Double click on Control Overrides and 
click New under Active Control Overrides. Set the following

– Controlled Element: PMP-2

– Attribute: Pump Status

– Value: On

– Start Date: 9/12/2016

– Start Time: 11:00:00 AM

– Duration: 4 hours

– Priority: 4 - Medium High.

11. Click OK. 
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12. The SCADAConnect Simulator should look like this: 

13. Click Compute. Review any user notifications, then close User Notifications and 
Calculation Summary.
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14. Look again at the previously created graph. View > Graphs > Graph -1.

With PMP-2 running, the water level in T-1 stays in a reasonable range as shown in 
the graph.
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